User Tools

Site Tools


Sidebar

how_to_update_atavism

Updating the Atavism Server

Updating your atavism server to a new version has two stages, updating the files and updating the database.

Updating the Server Files

Each update of the atavism server comes with a full copy of all the server files, but if you have an existing version of the server already you only need to copy in the files that have changed or been added. The Changelogs found on the Wiki for each update will contain a list of all of the files that have changed and that need copied in.

If you have skipped a few versions you just need to copy in any files that have changed since the version you last installed.

Updating the Database

The Atavism Server rar comes with both the core database setup files and sql files to update the database to the latest version. When updating your server you can ignore the core sql files and instead run the update_commands sql files in the sql/updates folder. You need to run them in order of update.

For example if you have version 1.5 and are upgrading to 1.6.3 you need to run the following files in the order listed:

  • update_commands1_6.sql
  • update_commands1_6_2.sql
  • update_commands1_6_3.sql

But if you are running version 1.6.2 and are upgrading to the next version (version 1.6.3) then you only need to run the update_commands1_6_3.sql file.

Updating the Atavism Unity Package

From version 1.6.3 onwards there will be a separate update package that only contains the files that have changed from the last version of the Atavism-Unity package. These will need to be run in update order if you have skipped an update.

For example, if you go straight from version 1.6.3 to 1.8 (skipping 1.7) you will need to import the 1.7 package first into your Unity project.

how_to_update_atavism.txt · Last modified: 2016/02/01 19:24 (external edit)